稀物宝资源网

XiWuBao.com

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
龙之谷技术 龙之谷 龙之谷
查看: 304|回复: 0

[软件源码] 某手视频去水印解析 易语言纯源码 没有使用模块

[复制链接]

签到天数: 168 天

[LV.7]常住居民III

824

主题

850

帖子

862万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
8628901

最佳新人活跃会员热心会员推广达人宣传达人灌水之王突出贡献优秀版主荣誉管理论坛元老

发表于 2020-4-20 08:09:34 | 显示全部楼层 |阅读模式
某手视频去水印解析 易语言纯源码 没有使用模块的写法
如下图

.版本 2
.支持库 EThread
.支持库 dp1
.程序集 窗口程序集_启动窗口
.子程序 _按钮1_被单击
启动线程 (&解析, , )
.子程序 解析
.局部变量 http, 对象
.局部变量 Location, 文本型
.局部变量 mp4, 文本型
CoInitialize (0)
http.CreateObject (“WinHttp.WinHttpRequest.5.1”, )
http.RunMethod (“open”, “GET”, Text1.context, 假)
' http.SetProperty (“Option”, 6, 0)
http.RunMethod (“SetRequestHeader”, “Cookie”, “did=web_” + 取数据摘要 (ToBin (rnd (1, 50))))
http.RunMethod (“SetRequestHeader”, “User-Agent”, “Mozilla/5.0 (iPhone; CPU iPhone OS 13_2_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.3 Mobile/15E148 Safari/604.1”)
http.RunMethod (“send”, )
' Location = rightxm (http.文本方法 (“GetAllResponseHeaders”, ), “Location: ”, chr (13) + chr (10), , ))
mp4 = rightxm (http.GetProperty (“ResponseText”, ).取文本 (), “srcNoMark":"”, “"},"user":”)
http.Clear ()
Text2.context = mp4
.子程序 rightxm, 文本型
.参数 srt, 文本型
.参数 ft, 文本型
.参数 bt, 文本型
.局部变量 fi, 整数型
.局部变量 bi, 整数型
fi = InStr (srt, ft, , 假)
fi = fi + len (ft)
bi = InStr (srt, bt, fi, 假)
return (mid (srt, fi, bi - fi))

附python源码对比
  1. import requests
  2. import random
  3. import string
  4. def http(url):
  5.     did = ''.join(random.sample(string.ascii_lowercase + string.digits, 32))
  6.     refere = {
  7.         'Cookie': 'did=web_' + did,
  8.         'User-Agent': "Mozilla/5.0 (iPhone; CPU iPhone OS 13_2_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.3 Mobile/15E148 Safari/604.1",
  9.     }
  10.     html = requests.get(url, headers=refere, allow_redirects=True)
  11.     mp4 = html.text.split("srcNoMark":"")[1].split(""},"user")[0]
  12.     return mp4
  13. url = "https://v.kuaishou.com/s/zeKwaYfN"
  14. result = http(url)
  15. print(result)
复制代码


另发,发现python对中文变量支持还是蛮好的,皮皮虾去水解析 中文变量测试

  1. import requests
  2. import json
  3. def 根据id解析(id):
  4.   try:
  5.     协议头= {
  6.         'User-Agent': "Mozilla/5.0 (iPhone; CPU iPhone OS 13_2_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.3 Mobile/15E148 Safari/604.1",
  7.     }
  8.     url = 'https://is.snssdk.com/bds/cell/detail/?cell_type=1&aid=1319&app_name=super&cell_id=' + id
  9.     html文本 = requests.get(url,headers=协议头, allow_redirects=False)
  10.     json对象 = json.loads(html文本.text)
  11.     mp4链接 = json对象['data']['data']['item']['origin_video_download']['url_list'][0]['url']
  12.   except:
  13.     return '解析出错'
  14.   else:
  15.     return mp4链接
  16. 视频id = '6757615695728482574'
  17. 输出文本型 = 根据id解析(视频id)
  18. print(输出文本型)
复制代码




本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
        

↑↑↑↑↑↑↑↑↑如回复后不显示里面的东西请刷新一下页面↑↑↑↑↑↑↑↑↑

        

服务范围:

    1、专业提供网站模板主题、插件汉化、优化、PHP环境配置等服务请详询在线客服

      2、本站承接 各种网站 等系统建站、仿站、开发、定制等服务

        3、英文模板(主题)安装费用为120元/次,汉化主题网站首次安装20元(二次安装15元/次)

          4、龙之谷单机架设安装费100元/次

            5、其他单机安装架设费为100元/次

售后时间:

周一至周日: 10:00-23:00

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋| XiWuBao.com ( 琼ICP备19002752号-1 )

GMT+8, 2020-8-12 08:24 , Processed in 0.271460 second(s), 49 queries .

Powered by Discuz! X3.4

© 2001-2013 Comsenz Inc. 技术支持 by 稀物宝设计.

快速回复 返回顶部 返回列表